Statement on AWS & Dockerhub Outage

Incident Report for OnFinality Status Page

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 03:24 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 21:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 21:18 UTC

Identified

AWS:
OnFinality's core services are not impacted by the AWS outage, as we self-host the majority of our services on OnFinality Cloud. All running nodes, RPC services, and indexers are operating well.

Dockerhub:
Dockerhub is the most common image library used by nodes running on the OnFinality platform, and it has been impacted by the AWS outage.

If your Network uses a Dockerhub image, the following actions may not work at this time:
- Deploying new nodes
- Updating Images
- Restarting Nodes

Therefore, we recommend you avoid taking any actions on your dedicated nodes until Dockerhub has been fully restored.
Posted Oct 20, 2025 - 21:14 UTC
This incident affected: Customer Portal.